Clients randomly stuck at windows logo

Clients randomly stuck at windows logo   
Exchange information related to diskless system, diskless solution, diskless software and so on.

Moderator: Youngzsoft Yao

Clients randomly stuck at windows logo

Postby Cemara Net » Sun Jan 27, 2019 10:36 am

I hope fellow ccboot staff / other members could help me solve this strange issue.
Here's my network topology, USB copying is a necessity at my place.

Image

For about 2 years, I've been having random occasions where new clients cannot boot and stuck at windows screen for a very long time.
The problem is, it doesn't happen constantly and that makes it very difficult to track the exact cause.

What always works to solve it is : rebooting the switch.
At one time rebooting the printer PC also solves the issue, but this doesn't seem to help it anymore.
There's also once occasion where rebooting the switch didn't help.
My server's disks are all ssd / nvme, i just replaced the writeback few weeks ago but it doesn't seem to help.
On the ccboot logs, the stuck client stops at "loading personal disk #clientnumber"
But replacing the personal disk with ssd doesn't help, it still happens few days afterwards.

Since rebooting the switch almost always solves the issue, i believe it has something to do with networking.
But ive made sure i follow ccboot wiki on optimizing NIC, Flow control is already disabled on clients, server NIC and switch.

Another possibilty is USB copying, but i've also had few occasions where this issue happens during slow hours where there arent many people playing

When it finally boots to windows, and it takes long time, it shows this :

Image
User avatar
Cemara Net
 
Posts: 8
Joined: Sat Feb 14, 2015 6:50 am

Re: Clients randomly stuck at windows logo

Postby icafeman » Wed Jan 30, 2019 3:40 am

Hi,
Try a new image once, with just flow control disable for client NIC properties.

and see if the issue occurs again.
User avatar
icafeman
Site Admin
 
Posts: 264
Joined: Wed Oct 30, 2013 7:25 am

Re: Clients randomly stuck at windows logo

Postby icafeman » Wed Jan 30, 2019 11:01 am

Please contact us at http://help.youngzsoft.com
and provide remote access to your server so we can help you fix it.

Thank you
User avatar
icafeman
Site Admin
 
Posts: 264
Joined: Wed Oct 30, 2013 7:25 am

Re: Clients randomly stuck at windows logo

Postby Cemara Net » Thu Jan 31, 2019 5:44 am

If flow control kicks in, would the server be able to ping the client?
Because i can still ping the troubled client normally.
Ok i will make another image and let you know if it's still troubling i'll give you the access
User avatar
Cemara Net
 
Posts: 8
Joined: Sat Feb 14, 2015 6:50 am

Re: Clients randomly stuck at windows logo

Postby icafeman » Tue Feb 05, 2019 6:27 pm

OK
once you have tried,
Please contact us at http://help.youngzsoft.com
or message us in skype - youngzsoft103

Thank you
User avatar
icafeman
Site Admin
 
Posts: 264
Joined: Wed Oct 30, 2013 7:25 am


Return to CCBoot